Sunday, October 30, 2011

28MHz QRSS beacon

Well, as promised elsewhere - a quick update on where I am with the 10m QRSS beacon project. 

I decided not to bury it!  Instead its going to live on the rack here in the shack / server room. Temps in here are fairly constant, but I decided to try adding a thick layer of thermal insulation around the beacon to elevate its temp to help buffer it from minor temp changes in here.  This may not be ideal!

Read on...

Here we see the completed beacon PCB inside a diecast box.

The device poking through the lower edge of the box is a thermocouple. It is directly above the oscillator crystal - so should give a direct readout of the temperature inside the box nearest the xtal.

This can be seen in more detail in this image.

Here we see it with the lid on the diecast box, inside its outer casing. The thermocouple is showing at that stage about 4 degrees above room temp - and a current drain of 90mA.

Now we see the digital thermometer mounted on the front panel, along with keyswitch and power LED.

The next stage was adding the thermal insulation - in this case polystyrene beads.

.... until it looks like this.

And then we quickly screw the lid down before all the beads escape!

And there it is sat on the rack.

So, tests began about 5 hours ago. Once every five minutes I recorded the xtal temp, and the frequency in Hz (audio) with my RX set to 28.000 MHz CW.

The beacon is at present TXing into a dummy load with lose coupling to the RX. (Im still torn between a half wave end fed vert and a halo when I do get an antenna up - but thats another story!)

Im using my usual studio quality soundcard (24bit) to sample the recovered audio from the RX, and used Baudline (an audio analysis tool) to take measurements of the frequency of the mark and space tones. This provides an accuracy roughly on a par with my frequency counter, (limited by the unknown drift on my RX in fact) but makes it easier to read the changing frequencies brought about by the FSK which on a counter is a bit of a pain.

yes - the FSK is a bit on the high side - about 8Hz - I was aiming for 5 but with the lid on and temp up the FSKing is also slightly increased.

These were the figures for the first 3 hours:

 (Raw data follows.)

mins  temp C  freq Hz
0     25      760
5     25.6    748
10    26.9    741
15    28.2    740
20    29.4    742
25    30.5    748
30    31.7    758
35    32.5    766
40    33.3    769
45    34.2    772
50    34.9    775
55    35.5    778
60    36.2    782
65    36.8    787
70    37.2    792
75    37.7    794
80    38.2    799
85    38.5    801
90    38.9    805
95    39.3    809
100   39.5    811
105   39.8    815
110   40.1    817
115   40.3    820
120   40.5    822
125   40.8    824
130   40.9    826
135   41.1    828
140   41.2    830
145   41.3    832
150   41.5    833
155   41.6    834
160   41.8    835
165   41.9    837
170   42.0    839
175   42.1    839
180   42.1    840

After 3 hours I stopped taking five minutely readings, and checked sporadically.

After 5 hours the Xtal temp had reached 43.5cand the frequency had reached 858Hz thats around 100Hz moved for around 20c temp change.

Although the values where beginning to flatten off, I pulled the plug after 5 hours as I feel that the thermal insulation is perhaps just a little too efficient!

Looking at the mark and space data on the display it was clear that once the xtal temp was past 33c that there was slightly more 1Hz jitter on the signal. No tests done to confirm this or the cause yet - but Im guessing that the PA transistor is sitting a fair bit warmer than the xtal and may be running away a little.

My main worry though is that as this will be operating as a MEPT (Manned Experimental Propagation Transmitter) to remain within licencing conditions it  will spend some quite sizeable times powered off when Im not physically here. The long ramp up time to stability  is not going to be condusive to a device that is turned on and off frequently. (As I am writing this the temp has dropped by over 3 degrees in 8 minutes, showing that cool down is much swifter than warm-up).

I think I may need to add a simple heater circ to the diecast box for more rapid warm ups, and to limit the upper temp to about 30c.

More tests will follow...


  1. Very very interesting tests, we look forward to seeing you on 10m QRSS.

    73 Colin - G6AVK

  2. Ok - 1st quick update:

    A LOT!! of the internal heating in the diecast box itself is coming from the 5v reg - if you have it plugged into a 13.8v shack supply thats a LOT of volts that have to go somewhere as heat.

    Ive taken the beacon off a direct 12v supply and dropped in a reasonably well smoothed 7.3v supply to it. Quick finger tests onto the tab on the v reg confirm a big reduction in heating.

    No time right now, but later tonight I will try and re-run the first hour of the previous tests at 7.3v and report back drift.

  3. I notice the LPF coils are wound tight on the toroids. Normally the rated inductance is when 60 to 80% of the former is used.
    The toroid turns are 1 turn short (9 and 10) vs the G QRP coils using the same values of capacitor. ( 10 & 11 turns)
    I have tested the LPF on the Hans Summers TX with the 10 and 11 turns and loss is slightly less than 0.5 dB.
    It is interesting that you have positive frequency shift with increasing temperature. Are the capacitors in the oscillator feedback NP0 or have they another colour on top?

    Keep up the good work

  4. Yes you are of course correct, windings are only over about a 3rd rather than the correct 2/3rds of the core, though when I quickly measured them on my LCR bridge the effect of a smaller winding group was quite minimal and made for an easier mount on the PCB.

    I have been working on a project for the last week or so, so not had chance to play any further with the beacon, but had already wondered about the efficiency of the LPF, as comparing it to the figures on the G-QRP site - as you comment the turns are 1 low. This coupled with my close wind may well make a worthwhile improvement, so when I next have some bench time that will be one of the first jobs.

    As for the positive freq slope with temp - yes I assumed they were NP0 but have not confirmed that.

    I also noticed that the antenna I slug up, a simple half wave zepp is somewhat weather sensitive - when it rains or is foggy and water builds up on the 400R ribbon cable the SWR goes from near unity up to around 2.8:1 which ends up pulling the TX freq by a few hz.

    So - before Im back on the air, there will have to be an antenna swap to something a bit more stable too.

    Ive also got a half built and tested active heatuing / cooling system built on the bench - but again not had time to finish - Im using and ATtiny with a TMP36 temp sensor to turn on/off a small pc fan for cooling and a low value metal case wire wound resistor which will be bolted to the diecast box. Hopefully with this combination I can hold the box at a fairly constant 40c.

    More updates when I have time...

  5. OK - A quick update:

    I rewound the coils using correct 60% of torroid and using 10-11-10 as per the GQRP page.

    Wheras I was seeing 4.4v p2p into 50R Im now only seeing 3.6v p2p, which by my maths is actually a drop to 32.4mW.

    The waveform on the scope looks pretty similar - possibly a little cleaner so it may be that previously I was including a sniff or two of some harmonics.

    This is confirmed by the fact that I have 4.5v on the input of the filter with a lot of rough edges.

    Hopefully I will get chance to run some slightly more subjective tests with an analyser and a sweep gen at some stage later to see exactly what the LPF looks like now.